среда, 15 августа 2018 г.

Клиент SNTP в MikroTik

  Начиная с версии прошивки 6.27 в MikroTik имеется соединение с облаком Cloud (IP – Cloud), позволяющем синхронизировать время на MikroTik, который не имеет энергонезависимого источника питания.


Детальных сведений в сети на русском языке о синхронизации времени через Cloud мне найти не удалось. Единственная найденная мной информация на Wiki MikroTik указывает, что:

а) точность устанавливаемого времени при выключенном клиенте NTP может составить несколько секунд: approximate time (accuracy of several seconds, depends on UDP packet latency, useful when NTP is not available);

б) опросы производятся каждые 60 секунд, а ожидание ответа от Cloud составляет 15 секунд: Router checks for outgoing IP address change: every 60 seconds
Router waits for cloud server response: 15 seconds

в) при включённом режиме Cloud зашифрованные пакеты upd передаются на порт 15252 узла cloud.mikrotik.com: UPD When enabled '/ip cloud' will send encrypted packets to hosts UDP/15252 port that resolves from cloud.mikrotik.com

Если на MikroTik нужен сервер NTP, синхронизация времени в Cloud отключёна (галочка в поле "Update Time" отсутствует), а клиент DHCP не настроен или не получает адресов серверов NTP от провайдера (Use Peer NTP),


то имеется необходимость настройки клиента NTP (SNTP Client).

Встроенный в MikroTik клиент SNTPклиент получает синхронизацию от серверов времени NTP. При его активизации (System – SNTP Client) вводятся адреса IP основного и дополнительного серверов точного времени NTP, например:


Если вместо адреса IP водить имена конкретных серверов, то клиент распознает их адреса IP и автоматически подставит необходимые значения.

В процессе работы клиент опрашивает основной и дополнительный серверы, выбирает из них наилучший и синхронизирует с ним своё время. После успешной синхронизации времени повторный цикл "опрос – выборы – синхронизация" проводится через 64 секунды, затем интервал между циклами возрастает (128, 256, 300 секунд), пока не достигнет значения в 900 секунд.


Клиент SNTP MiroTik имеет недостаток. Дело в том, что адреса IP серверов точного времени могут меняться. В частности, в течение суток при пингах сервера времени timeserver.ru были возвращены значения 185.22.183.74 и 185.22.183.73  Клиент же SNTP MikroTik такие изменения не отслеживает, продолжая использовать предыдущий адрес IP. Поэтому может возникнуть ситуация, при которой синхронизация времени произведена не будет и в поле (см. рис. выше) Last Bad Packet From будет указан IP сервера NTP, с которым ему синхронизироваться не удалось.

Можно, конечно, периодически пингом опрашивать доступность введённых IP серверов NTP и при изменении их IP вносить новые адреса, а можно доверить решение данного вопроса скрипту автоматической коррекции адресов серверов IP.

Сам скрипт заимствован с одного из комментариев то ли к публикации на сайте, то ли одного из форумов (сейчас уже и не вспомню). Надеюсь, что автор комментария не станет мне выставлять претензию на "нарушение его авторских прав", тем более что, по его же словам, текст скрипта "//честно стибрен с официальной вики".

Текст скрипта следующий:

# Change the following line as needed as progName should match script name
:local progName "SetNtpServers";

# Array of NTP pools to use (check www.pool.ntp.org) one or a maximum of two, a primary & secondary
# Modify the following line and array variable based on your locale (default is north america).
:local arrNtpSystems ("0.us.pool.ntp.org", "1.us.pool.ntp.org");
# Alternatively the US related pool below can be used.
#:local arrNtpSystems ("0.us.pool.ntp.org", "1.us.pool.ntp.org");
#
# No modification is necessary beyond this line.
:put "$progName: Running...";
:log info "$progName: Running...";
:set arrNtpSystems [ :toarray $arrNtpSystems ];
:if (( [ :len $arrNtpSystems ] < 1 ) or ( [ :len $arrNtpSystems ] > 2 )) do={
:put "$progName: ERROR NTP Systems array (\$arrNtpSystems) must be either one or two DNS names.";
:log info "$progName: ERROR NTP Systems array (\$arrNtpSystems) must be either one or two DNS names.";
} else={
:local arrRosNtpSetting ("primary-ntp", "secondary-ntp");
:local i 0;
:foreach strNtpSystem in ($arrNtpSystems) do={
:local ipAddrNtpSystem [ :resolve $strNtpSystem ];
:local strRosNtpSetting [ :pick $arrRosNtpSetting $i ];
:local strCurrentNtpIp [ /system ntp client get $strRosNtpSetting ];
:put "$progName: NTP server DNS name $strNtpSystem resolves to $ipAddrNtpSystem.";
:log info "$progName: NTP server DNS name $strNtpSystem resolves to $ipAddrNtpSystem.";
:put "$progName: Current $strRosNtpSetting setting is $strCurrentNtpIp.";
:log info "$progName: Current $strRosNtpSetting setting is $strCurrentNtpIp.";
:if ( [ :toip $ipAddrNtpSystem ] != [ :toip $strCurrentNtpIp ] ) do={
:put "$progName: Changing $strRosNtpSetting setting to $ipAddrNtpSystem.";
:log info "$progName: Changing $strRosNtpSetting setting to $ipAddrNtpSystem.";
:local strCommand [ :parse "/system ntp client set $strRosNtpSetting=\"$ipAddrNtpSystem\"" ];
$strCommand;
} else={
:put "$progName: No changes were made for the $strRosNtpSetting NTP setting.";
:log info "$progName: No changes were made for the $strRosNtpSetting NTP setting.";
}
:set i ($i + 1);
}
}
:put "$progName: Done.";
:log info "$progName: Done.";

Обратите внимание на строку

       :local arrNtpSystems ("0.us.pool.ntp.org", "1.us.pool.ntp.org");

В ней указаны серверы NTP. Вы можете указать свои серверы NTP или пулы серверов NTP.

Какие адреса серверов NTP использовать? Можно их поискать. Например, при просмотре результатов русскоязычного поиска меня заинтересовал ntp.time.in.ua (подробности), в описании которого указано, что он имеет 1-й уровень точности. А сервер в Донецке уровня stratum2 на своей странице даже покажет смещение часов компьютера.

Можете указать целые пулы серверов NTP, для чего кликните на регион и на странице найдите страну своего пребывания:


Например, для Российской Федерации найдены записи:

0.ru.pool.ntp.org
1.ru.pool.ntp.org
2.ru.pool.ntp.org
3.ru.pool.ntp.org

Результирующий текст скрипта (без воды в виде комментариев) будет следующим (пример):

:local progName "SetNtpServers";
:local arrNtpSystems ("0.ru.pool.ntp.org", "1.ru.pool.ntp.org");
:put "$progName: Running...";
:log info "$progName: Running...";
:set arrNtpSystems [ :toarray $arrNtpSystems ];
:if (( [ :len $arrNtpSystems ] < 1 ) or ( [ :len $arrNtpSystems ] > 2 )) do={
:put "$progName: ERROR NTP Systems array (\$arrNtpSystems) must be either one or two DNS names.";
:log info "$progName: ERROR NTP Systems array (\$arrNtpSystems) must be either one or two DNS names.";
} else={
:local arrRosNtpSetting ("primary-ntp", "secondary-ntp");
:local i 0;
:foreach strNtpSystem in ($arrNtpSystems) do={
:local ipAddrNtpSystem [ :resolve $strNtpSystem ];
:local strRosNtpSetting [ :pick $arrRosNtpSetting $i ];
:local strCurrentNtpIp [ /system ntp client get $strRosNtpSetting ];
:put "$progName: NTP server DNS name $strNtpSystem resolves to $ipAddrNtpSystem.";
:log info "$progName: NTP server DNS name $strNtpSystem resolves to $ipAddrNtpSystem.";
:put "$progName: Current $strRosNtpSetting setting is $strCurrentNtpIp.";
:log info "$progName: Current $strRosNtpSetting setting is $strCurrentNtpIp.";
:if ( [ :toip $ipAddrNtpSystem ] != [ :toip $strCurrentNtpIp ] ) do={
:put "$progName: Changing $strRosNtpSetting setting to $ipAddrNtpSystem.";
:log info "$progName: Changing $strRosNtpSetting setting to $ipAddrNtpSystem.";
:local strCommand [ :parse "/system ntp client set $strRosNtpSetting=\"$ipAddrNtpSystem\"" ];
$strCommand;
} else={
:put "$progName: No changes were made for the $strRosNtpSetting NTP setting.";
:log info "$progName: No changes were made for the $strRosNtpSetting NTP setting.";
}
:set i ($i + 1);
}
}
:put "$progName: Done.";
:log info "$progName: Done.";

При указании серверов точного времени рекомендуют использовать региональные пулы адресов серверов NTP. Хотя причина данной рекомендации больше обусловлена тем, что региональные серверы NTP просто географически ближе. А так разницы нет. Главное, чтобы какой-нибудь сервер NTP "не банил" Ваш IP.  Меня, например, смутила такая запись на странице https://ntp-servers.net/servers.html:

"При использовании наших NTP серверов, старайтесь не отправлять слишком много запросов за короткий промежуток времени, в противном случае ваш IP адрес может быть заблокирован на срок не менее 30 суток с момента начала блокировки."

Как понимать высказывание "слишком много запросов"? Запросы с моего MikroTik с интервалами 64, 128, 256 c. (см. пояснение выше) это "слишком много" или нормально?

При вводе имён серверов точного времени необходимо вводить так, как они указаны. Например:

:local arrNtpSystems ("ntp.time.in.ua", "ntp2.time.in.ua");

то есть без 0. и 1. перед их именами. В противном случае при запуске скрипта получите его бесконечное выполнение, связанное с невозможностью распознавания их адресов IP.

Создайте скрипт (System – Scripts)


укажите ему имя (в приводимом примере timeservers), а в поле Source вставьте текст скрипта.


Далее вызовите планировщик заданий "System – Sheduler", в котором определите с какого времени и с какой периодичностью производить запуск скрипта timeservers (или определённого Вами наименования скрипта):



В поле On Event впишите  /system script run имя_вашего_скрпта

Периодичность (Interval) установите такую, которую считает нужной. В приводимом примере она указана как 1d:00:00:00, то есть каждые 24 часа (раз в сутки). Если это нужно делать, например, каждые 4 часа, то укажите 00:04:00:00  То есть, формат представления состоит из 4 групп цифр – дней:часов:минут:секунд

После отработки скрипта в протоколе работы MikroTik (Log) должны появиться записи, касающиеся результатов выполнения созданного скрипта:


Если будут присутствовать строки "No changes made for the primary-ntp NTP settings" и "No changes made for the secondary-ntp NTP settings", то это означает, что адреса IP при их очередном распознавании не изменились и никаких изменений в IP адреса серверов точного времени клиента SNTP MikroTik внесено не было.

А в разделе System – SNTP Client можно посмотреть результат последней синхронизации времени. На рисунке ниже видно, что состоялись "выборы" и с наилучшим сервером произведена синхронизация часов MikroTik, в ходе которой осуществлена коррекция на 779 микросекунд.


Обратите внимание, что при добавлении сервера NTP такой подробной картинки в клиенте SNTP Вы наблюдать не будете. Вместо SNTP Client у Вас будет отображаться NTP Client c уведомлением о том, что время синхронизировано (synchronized).


Может возникнуть вопрос: зачем а настройках SNTP Client указано значение 192.168.224.81 в поле Server DNS Names, которое в приводимом примере соответствует адресу сервера DNS MikroTik в локальной сети.

Если Вами используется Peer DNS Names, то это поле можно и не заполнять. Но если Вы не используете имени серверов, предоставляемых провайдером, предпочитая для распознавания имён использовать другие DNS интернета, а в статических адресах DNS сервера MikroTik такие значения как time.windows.com, ntp.ubuntu.com, time.google.com указывают на определённые адреса IP, не совпадающие с их действительными значениями (например, ближайшим сервером NTP), то есть вероятность получить невозможность синхронизации времени клиентским компьютером (server-ip-mismatch).


Второй причиной ввода значений в поля Server DNS Names является ситуация, при которой сервер DNS MikroTik не используется, поэтому для распознавания имён серверов точного времени требуется указание адресов серверов DNS, используемых для преобразования имён серверов NTP в адреса IP. Это отражено в Wiki MiroTik.

В протоколе MikroTik работа скрипта помечена записями SetNtpServers. Чтобы установить своё наименование измените его в самой первой строчке скрипта:

       :local progName "SetNtpServers";

воскресенье, 12 августа 2018 г.

Сохранение страницы в 1 файл html в Chrome, Vivaldi, Yandex browser, Opera

Страницу в браузерах на кодовой базе проекта Chomium (Google Chome, Vivaldi, Яндекс браузер, Opera) можно сохранить в 1 файл html. Для установки расширения перейдите на соответствующий ресурс.

После установки на верхней панели браузера появится значок (на рисунке ниже –крайний справа). Рисунки приведены для браузера Slimjet.


Если на пустой странице кликнуть по указанному значку, то можно перейти к тонкой настройке расширения.



Кнопка "Reset" служит для сброса настроек в настройки по умолчанию. Каждая секция раскрывается. О расшифровке каждой из настроек читайте в аналогичной публикации для браузера Firefox.

Сохранение страницы также ничем не отличается от от такого же процесса в Firefox (подробности).

Похожими расширениями являются Print edit WE и инструменты сохранения страницы в файлы mht или mhtml (подробности).

вторник, 7 августа 2018 г.

Сохранение в Firefox страницы в 1 файл html

Страницу в Firefox можно сохранить в 1 файл html. Для установки дополнения перейдите на соответствующий ресурс.

После установки на верхней панели браузера появится значок (на рисунке крайний справа):


Откройте какой-либо ресурс и дождитесь полной загрузки страницы, после чего нажмите на значок дополнения.


При обработке страницы возле значка появится квадратик зелёного цвета,


а отображение сохраняемой страницы станет чуть затемнённым.

После завершения  обработки появится запрос на сохранение:


После сохранения на значке дополнения возникнет надпись OK.


Страница сохраняется в один файл html со всем отображаемым на нём содержимым и элементами оформления. При этом содержащая такие элементы дополнительная папка, как это происходит при стандартном сохранении страницы полностью, не создаётся.

Если при сохранении страницы Вам показалось, что процесс "завис", то подведите курсор к значку дополнения. На нём будет отображён процесс выполнения сохранения страницы в процентном отношении. Такая ситуация может наблюдаться при сохранении страниц, насыщенных мультимедийными элементами.


Дополнение имеет тонкие настройки. Перейдите в "Инструменты – Дополнения" или наберите в адресной строке about:addons  Найдите SingleFile


В этой же строке справа увидите


После нажатия на эту кнопку откроется меню настроек:


Для сброса настроек служит кнопка "Reset". Каждая из секций раскрывается.



Приблизительный перевод значений:

-------

Usr interface (внешний вид)

add entry in the context menu – добавить запись в контекстное меню браузера

overlay a shadow on the page during processing – затенять страницу во время обработки

display ad infobar when vieweing archives – полказывать информационную панель при просмотре архивов

display stats in the console after processing – показывать статистику в консоли после обработки

-------

File name (наименование файла)

append the save date to the file name – дообавить к имени файла дату сохранения

enter the file name before saving the page – ввести имя файла перед сохранением страницы

-------

Page content (содержание страницы)

compress HTML – сжимать HTML

remove HTML imports – удалять импорты в HTML

remove frames – удалить фреймы

remove hidden elements – удалить скрытые элементы

save raw page – сохранить исходную страницу


-------

Page resources (ресурсы страницы)

remove scripts – удалить скрипты

remove video sources – удалить источники видео

remove audio sources – удалить источники аудио

compress CSS – сжать CSS

remove unused CSS rules – удалить неиспользуемые правила CSS

save lazy loaded images – сохранить медленно загружаемые изображения

set a maximum size for embedded resourses – указать максимальный размер встроенных ресурсов

maximum size (Mb) – максимальный размер (Мб)


Аналогичными по функциональности дополнениями являются Save Page WE и Print-Edit-WE.

вторник, 31 июля 2018 г.

Запуск sudo mc без ввода пароля

Со временем возникла необходимость запуска sudo mc без ввода пароля суперпользователя. Для этого необходимо внести изменения в файл /etc/sudoers

В публикациях Интернет для редактирования этого файла приводится команда sudo visudo, за которой последует загрузка содержимого этого файла в редактор nano. Но так как к этому редактору, откровенно признаться, "душа не лежит", то можно воспользоваться любым другим редактором, запустив его от имени суперпользователя.  Ниже способы на выбор:

sudo mc и далее F4 по нужному файлу;

sudo xed /etc/sudoers  (sudo gedit /etc/sudoers для Ubuntu);

sudo thunar (для xfce) и далее перейти в каталог /etc, в котором открыть файл sudoers с помощью текстового редактора.

В последнем случае для Cimnnamon командой будет sudo nemo, а для MATE – sudo caja.

Перед внесением изменений рекомендуется ознакомиться с содержанием публикации "Ошибка синтаксиса sudoers" – читать здесь.

В конец файла добавляю строки поясняющего комментария и разрешительного действия:

# Midnight Commander
user ALL=NOPASSWD: /usr/bin/mc

user – это логин (имя) пользователя. У каждого он свой. Надеюсь, что свой Вы знаете. Если не знаете, то запустите терминал и посмотрите, что находится слева от символа @.

Далее оформляю себе значок (кнопку) запуска:



Теперь при запуске значка или по команде в терминале sudo mc Midnight Commander будет запущен с правами суперпользователя без запроса пароля.

понедельник, 30 июля 2018 г.

Как вернуть в Midnight Commander внутренний редактор по F4

На днях было замечено, что при вызове в Midnight Commander файла на редактирование (клавиша F4) запускается не встроенный редактор mncedit, а редактор nano. Очевидно, что где-то у меня "накосячено".

Для исправления ситуации необходимо внести изменение в файл настроек mc, который расположен в ~/.config/mc/ini


Несмотря на то, что данный файл расположен в Вашем домашнем каталоге ~/ , посмотреть и отредактировать его под своей учётной записью Вам не удастся, о чём свидетельствует крестик на значке каталога mc при просмотре содержимого ~/.config (для просмотра в файловом менеджере включить отображение скрытых файлов).


Для доступа к каталогу ~/.config/mc запустите файловый менеджер с правами суперпользователя (sudo thunar для xfce, sudo nemo для Cinnamon, sudo caja для MATE) и откройте в текстовом редакторе файл ini.


Этот файл можно сразу открыть в текстовом редакторе по команде

в Linux Mint:  sudo xed ~/.config/mc/ini

в Ubuntu:  sudo gedit ~/.config/mc/ini

Найдите строку use_internal_edit= и если её значение равно 0 как на рисунке,


то исправьте 0 на 1 и сохраните файл. Запустите Midnight Commander. По клавише F4 должен запускаться внутренний редактор mcedit.

суббота, 14 июля 2018 г.

Linux Miint 19. Настройка системы после установки


Содержанием публикации не является репостинг публикуемых из года в год различными сайтами материалов о настройке Linux Mint и Ubuntu после установки. Представляемые здесь сведения касаются произведённых настроек системы, исходя из потребностей личного использования и приобретённого опыта. Установка Linux Mint 19 была произведена на реальное железо, а не на виртуальную машину в VirtualBox.

Рассматриваемые вопросы:

отключение в менеджере обновлений напоминания о создании снимков системы;

 переопределение файла подкачки;

удаление неиспользуемого мной ПО и установка нужного ПО;

настройка автозапускаемых приложений;

отключение ненужных системных служб;

удаление ненужных языков и шрифтов;

субъективное мнение о теме оформления Mint-Y;

стоит ли обновляться до Linux Mint 19 ?


Отключение напоминания о создании снимков системы

После установки при обновлении системы в менеджере обновлений присутствует баннер:


TimeShift является новинкой в Linux Mint 19, назначение которого понятно из пояснения (кликните по картинке).

Однако за 5 лет использования именно Linux Mint обновления моей системы включали уровни 4 и 5, то есть устанавливались все компоненты. За это время мной ни разу не было замечено нестабильной работы системы после установки этих обновлений. Выражаю согласие с мнением, что самым "страшным" явлением для Linux является сам пользователь.

Вторым "против" является необходимость учёта расхода дискового пространства под нужды TimeShift. Что это такое и сколько будет израсходовано дискового пространства читайте в статье Алексея Федорчука. Так как в дальнейшем TimeShift мной использоваться не будет, то данный баннер отключаю путём снятия галочки в поле "Показывать предупреждение, если создание снимков системы не настроено":


В менеджере обновлений доступна новая настройка, позволяющая осуществлять обновление системы в автоматическом режиме (фоновая задача от имени root):


По умолчанию галочка в поле "Устанавливать обновления автоматически" отсутствует. Если её поставить, то системой в каталоге /etc/cron.daily будет создан файл mintupdate с содержанием:

#!/bin/bash

/usr/bin/mintupdate-cli upgrade --refresh-cache --yes > /var/log/mintupdate.log 2>&1

В какое время в этом случае производится ежедневный запуск?

В файле /etc/crontab читаем:

25 6 * * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )

Учитывая синтаксис crontab, запуск ежедневных заданий производится в 6 часов 25 минут утра. Ваш компьютер будет в такое время работать?

Если Вы установите галочку, а затем решите отказаться от автоматического обновления, то файл mintupdate системой будет удалён.

Если Вы, всё-таки, желаете продемонстрировать "крутость" и обновлять систему автоматически, то подумайте, в какое время суток Ваш компьютер точно будет работать и, в соответствии с данным соображением, выполните в терминале команду sudo xed /etc/crontab и вместо 25 6 укажите своё время (минут час). Например, для запуска от имени root ежедневных заданий cron.daily в 8 часов 30 минут вечера строка будет иметь вид:

30 20 * * * root test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily )


Переопределение файла подкачки (swap)

В новых редакциях Ubuntu и Linux Mint при создании разделов только / (корневого) или / и /home (корневого и раздела под домашние каталоги) при установке системы автоматически создаётся файл подкачки swap. В разных условиях его размер будет разным. Например, при установке системы с носителя flash на компьютер с оперативной памятью 4 Гб при различных вариантах его указания в BIOS были созданы файлы подкачки:

UEFI: USB DISK 2.0 PMAP – 903 Мб

USB: USB DISK 2.0 PMAP – 2,1 Гб.

Так как мной устанавливалась система с графическим окружением xfce, то подобные размеры файла подкачки представляются мне слишком "жирными". Исходя из трёхлетнего опыта использования xfce, даже при запуске очень "тяжёлых" приложений и служб файл подкачки в 254 Мб никогда не был использован в полном объёме. Поэтому для переопределения файла подкачки в 254 Мб будут произведены действия:

– отключение файла подкачки;

– удаление существующего файла подкачки;

– создание нового файла подкачки в 254 Мб;

– подключение созданного файла подкачки к сеансу работы в системе.

Указанные выше действия выполняются командой в терминале (в одну строку):

sudo swapoff -a && sudo rm /swapfile && sudo dd if=/dev/zero of=/swapfile bs=1M count=254 && sudo mkswap /swapfile && sudo swapon /swapfile

Если Вам необходим другой размер файла подкачки, то вместо 254 укажите своё значение в Мегабайтах.

После этого целесообразно осуществить настройки, суть которых изложена в этой публикации. Указанные там цифры следует воспринимать не как готовый "рецепт", а как пример настройки конкретной системы. К данным настройкам необходимо подойти вдумчиво, учитывая особенности использования своей системы.


Удаление неиспользуемого мной ПО и установка нужного

К неиспользуемому мной на компьютере ПО относятся:

– простое сканирование (simple-scan) по причине отсутствия сканера;

– сервис заметок Tomboy (tomboy);

– мультимедийный проигрыватель Rhythmbox (rhythmbox), вместо которого использую Audiocious самой последней версии, устанавливаемый через репозиторий webupd8;

– программа сообщений HexChat (hexchat);

– автоматическая подстройка "теплоты" свечения монитора  Redshift (redshift);

– экранная клавиатура Onboard (onboard);

– ПО создания снимков системы TimeShift (timeshift);

– поддержка RAID (dmraid) – подробности;

– диспетчер логических массивов LVM (lvm2) – подробности;

– создание соединений через ppp (подробности);

– использование openvpn (подробности).

К используемому мной ПО, отсутствующему в стандартной поставке Linux Mint, относятся проигрыватель Audiocious, файловый менеджер Midnight Commander, монитор процессов htop, который для оценки нагрузки на ЦП и расхода оперативной памяти представляется мне более удобным, чем "Диспетчер задач":


Кроме того, у меня имеется заинтересованность получать оперативные обновления офисного пакета Libre Office, что возможно через подключение официального репозитория ppa:libreoffice/libreoffice-6-0

С целью полного удаления ПО из системы будет использована команда:

sudo apt purge -y (-y означает, что никаких вопросов задаваться не будет).

Для установки будет использована команда:  sudo apt install -y

Учитывая описанное выше, в терминале выполняется команда (в одну строку):

sudo apt purge -y rhythmbox hexchat onboard redshift timeshift simple-scan tomboy dmraid lvm2 ppp openvpn && sudo add-apt-repository -y ppa:nilarimogard/webupd8 && sudo add-apt-repository -y ppa:libreoffice/libreoffice-6-0 && sudo apt update && sudo apt install -y audacious htop mc


Настройка автозапускаемых приложений

Здесь всё просто. Обратитесь к настройкам, которые зависят от установленного у Вас графического окружения: Cinnamon, MATE, xfce. Например, для xfce: "Настройки – Сеансы и запуск – Автозапуск".

Например, перечисленным выше не пользуюсь:




Если Вами настроено автоматическое обновление от имени root (см. выше), то к этому можно добавить:



Отключение ненужных системных служб

Для установленной ранее системы Linux Mint 18.2 xfce проводился анализ, результатом которого явилось написание этой публикации. В Linux Mint 19 был осуществлён аналогичный анализ.

Были выполнены команды:

sudo systemctl list-units --type service

systemd-analyze plot > graph.svf

В результате выполнения sudo systemctl list-units --type service был получен результат: 53 loaded units listed.

Кое в чём имелись и отличия. Например, в новой системе не найдена была служба geoclue.service, а найдена apport.service

Apport в Ubuntu  это классический crash reporter, позволяющий выяснить причину падения программы и исправить её в следующей версии. Apport  это мостик между разработчиком программы и пользователем, у которого на компьютере программа ведёт себя не так как задумывалось. 

После анализа файла graph.svf (читается через браузер) возник вопрос: что такое networkd-dispatcher.service.

NetworkManager Dispatcher Service – это сервис, который при изменении состояния NM, дёргает скрипты из каталога /etc/NetworkManager/dispatcher.d и передает в них в качестве параметров командной строки имя сетевого интерфейса, у которого изменилось состояние, и новое значение этого самого состояния - up или down (vpn-up и vpn-down для VPN-соединений). 

Исходя их найденного в Интернет описания, сначала возникло желание отключить службу. Но при обращении к каталогу dispatcher.d замечены присутствие файла ntp и файлов, отвечающих за настройку dhcp IP версий 4 6.

Кроме того, уже забылось, что такое apparmor. AppArmor – программный инструмент упреждающей защиты, основанный на политиках безопасности (известных также как профили (англ. profiles)), которые определяют, к каким системным ресурсам и с какими привилегиями может получить доступ то или иное приложение. В AppArmor включён набор стандартных профилей, а также инструменты статического анализа и инструменты, основанные на обучении, позволяющие ускорить и упростить построение новых профилей. AppArmor работает в фоновом режиме, поэтому Вы можете не знать, что это такое и что AppArmor делает.

Поэтому, после некоторого периода "задумчивости", решено было деактивировать: apport.service, avahi-daemon.service, cups-browsed.service, ModemManager.service, speech-dispatcher.service.

Данное действие было выполнено командой в терминале:

sudo systemctl disable apport.service && sudo systemctl disable avahi-daemon.service && sudo systemctl disable cups-browsed.service && sudo systemctl disable ModemManager.service && sudo systemctl disable speech-dispatcher.service


Удаление ненужных языков и шрифтов

За основу был взят материал, посвящённый удалению ненужных шрифтов в Linux Mint 18.3. Несмотря на большую степень схожести, выявлены особенности: некоторые "ненужные" шрифты отсутствуют изначально, а некоторые, наоборот, появились.

 Действия, которые необходимо предпринять.

1. Удалить ненужные языки, запустив "Параметры системы" – "Языки". Для русскоязычного пользователя для своих нужд оставлены русский и США.

Что такое русский, Украина, убейте меня веником, не понимаю. Может быть, всё-таки, украинский? Тогда вопрос о правильном наименовании языкового пакета необходимо адресовать команде разработчиков Linux Mint.


2. Скачать архив и распаковать в удобное для себя место. Архив содержит недостающие шрифты Microsoft, отсутствующие в ttf-mscorefonts-installer, а также шрифты noto (взяты из свежеустановленного Linux Mint 19). В процессе удаления шрифтов набор noto удаляется полностью, так как по отдельности компоненты данного набора шрифтов не удаляются. А поскольку наиболее приемлемое отображение подписей к значкам и заголовков окон обусловлено именно шрифтом noto, то его присутствие в системе необходимо. Из набора noto убраны именно те компоненты, которые относятся к неиспользуемым в дальнейшем языкам.

Содержание каталога noto из состава архива:


3. Выполнить удаление шрифтов и установку пакета ttf-mscorefonts-installer.

4. Добавить в каталог шрифтов шрифты из состава скачанного архива.

Почему бы удаление шрифтов не производить через менеджер программ? К сожалению, при обращении к менеджеру программ перечисление шрифтов заканчивалось указанием на


А установленные шрифты, начинающиеся с fonts-lo... уже не отображаются, те же fonts-noto.

На приведенных ниже рисунках показаны шрифты в системе до осуществления перечисленных выше мероприятий и после них.



Удаление "ненужных" шрифтов и установка пакета ttf-mscorefonts-installer производится в терминале командой в одну строку. Команда написана таким образом, что никаких вопросов задаваться не будет. В процессе выполнения команды можно увидеть выводимую информацию, что для удаления отмечено 93 пакета, а после данной операции объём занятого дискового пространства уменьшится на 201 Mб.

Пользователям Cinnamon

Ранее при использовании мной Linux Mint Cinnamon при команде удаления пакета fonts-wqy-microhei система выдала "грозное" предупреждение, что вместе с ним будут удалены компоненты Cinnamon. Поэтом при использовании Linux Mint Cinnamon с целью своего спокойствия удалите из приведенной ниже команды запись fonts-wqy-microhei. В дальнейшем можете попробовать выполнить в терминале команду sudo apt purge fonts-wqy-microhei, но так как при выполнении этой команды потребуется подтверждение действия, то увидите от системы предупреждение, если это будет последствия этого действия будут представлять опасность для Cinnamon.

Выполните в терминале команду:

sudo apt purge -y fonts-nanum fonts-gujr-extra fonts-guru-extra fonts-telu-extra fonts-knda fonts-beng-extra fonts-deva-extra fonts-guru fonts-orya fonts-telu fonts-beng fonts-mlym fonts-taml fonts-gujr fonts-lohit-taml-classical fonts-deva fonts-takao-pgothic fonts-khmeros-core fonts-indic fonts-navilu fonts-kalapi fonts-lao fonts-gubbi fonts-sahadeva fonts-pagul fonts-tlwg-garuda fonts-tlwg-garuda-ttf fonts-tlwg-kinnari fonts-tlwg-kinnari-ttf fonts-tlwg-laksaman fonts-tlwg-laksaman-ttf fonts-tlwg-loma fonts-tlwg-loma-ttf fonts-tlwg-mono fonts-tlwg-mono-ttf fonts-tlwg-norasi fonts-tlwg-norasi-ttf fonts-tlwg-purisa fonts-tlwg-purisa-ttf fonts-tlwg-sawasdee fonts-tlwg-sawasdee-ttf fonts-tlwg-typewriter fonts-tlwg-typewriter-ttf fonts-tlwg-typist fonts-tlwg-typist-ttf fonts-kacst fonts-orya-extra fonts-noto fonts-nakula fonts-tlwg-typo fonts-tlwg-typo-ttf fonts-tlwg-umpush fonts-tlwg-umpush-ttf fonts-tlwg-waree fonts-tlwg-waree-ttf fonts-lohit-deva fonts-lohit-gujr fonts-lohit-guru fonts-lohit-knda fonts-lohit-mlym fonts-lohit-orya fonts-lohit-taml fonts-lohit-telu fonts-samyak-deva fonts-samyak-gujr fonts-samyak-mlym fonts-samyak-taml fonts-kacst-one fonts-lohit-beng-assamese fonts-lohit-beng-bengali fonts-sil-padauk fonts-lklug-sinhala fonts-noto-cjk fonts-tibetan-machine fonts-wqy-microhei fonts-noto-color-emoji fonts-noto-hinted fonts-noto-mono fonts-noto-unhinted fonts-sil-abyssinica fonts-thai-tlwg fonts-smc fonts-smc-anjalioldlipi fonts-smc-chilanka fonts-smc-dyuthi fonts-smc-karumbi fonts-smc-keraleeyam fonts-smc-manjari fonts-smc-meera fonts-smc-rachana fonts-smc-raghumalayalamsans fonts-smc-suruma fonts-smc-uroob && sudo apt install -y ttf-mscorefonts-installer

После этого запустите с правами суперпользователя предпочитаемый Вами менеджер файлов. Примеры: sudo mc, sudo nemo, sudo caja, sudo thunar.

Каталог noto из архива поместите в /usr/share/fonts/truetype

Содержимое каталога msttcorefonts – в /usr/share/fonts/truetype/msttcorefonts



Субъективное мнение о теме оформления Mint-Y

В Linux Mint 19 тема Mint-Y является дефолтной. При беглом взгляде на неё лично у меня возникли противоречивые впечатления.

С одной стороны  "красота неописуемая". С другой – некоторые значки, предназначенные для отображения на панели, являются изображениями светлого цвета и при попытке перейти на старую тему Mint-X их увидеть весьма затруднительно. На представленных ниже изображениях первые два соответствуют теме оформления Mint-Y, а вторые два – Mint-X.






Кроме того, эмблемы на таких домашних каталогах как Видео, Документы, Загрузки, Изображения, Музыка, Общедоступные, Шаблоны стали меньше и теперь являются монохромными, что для привыкшего к значкам Mint-X пользователю будет непривычным.




Стоит ли обновляться до Linux Mint 19?

В целом, имею склонность согласиться с опубликованным командой разработчиков Linux Mint замечанием, что если Вас устраивает используемая Linux Mint, то нет смысла переходить на Linux Mint 19 в надежде получить какие-то новые функции.

Цитирование русского перевода c форума linuxmint.com.ru:

Нужно ли вам обновляться?

Linux Mint 17.x (17, 17.1, 17.2 и 17.3) будут поддерживаться до 2019 года.
Linux Mint 18.x (18, 18.1, 18.2 и 18.3) будут поддерживаться до 2021 года.

Если ваша версия Linux Mint всё ещё поддерживается, и вы довольны своей текущей системой, тогда нет нужды в обновлении.